当前位置:首页 > 问答

指南针长线决策指标公式

我来帮TA回答

跪求 如下图 指南针全赢指标 :拉升动能 如有此指标的发邮箱2323581264@qq.com

您多累啊。。现在都不用这个了很久了,,,还什么指标啊。。。。水平太低。。。实话实说。没有其他意思。。。

指南针公式源码如何导入指标平台

飞狐,大智慧通用指南针指标公式(一共21个公式)原码
1,CYW主力控盘
VAR1:=CLOSE-LOW;
VAR2:=HIGH-LOW;
VAR3:=CLOSE-HIGH;
VAR4:=IF(CLOSE>=0,(VAR1/VAR2+VAR3/VAR2)*VOL,(VAR3/VAR2+VAR1/VAR2)*VOL);
SUM(VAR4,10)/10000, COLORSTICK;
2,CYW-YJJ主力控盘
VAR1:=1;
VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,P1)/SUM(VAR5,P1);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,P1);
VAR9:=EMA(VAR8,P2);
VARA:=EMA(VAR8,P3);
MO: (VAR8-VARA)*VAR1;
ML: (VAR9-VARA)*VAR1;
MODE: MO*VAR1, COLORSTICK;
p1:=0,100,6
p2:=0,100,8
p3:=0,100,45
3,CYS盈亏指标
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
Var4:=MA(Var1,N3);
Var5:=DMA(CLOSE,VOL/CAPITAL);
CYS5: 100*(CLOSE-Var2)/Var2;
CYS13: 100*(CLOSE-Var3)/Var3;
CYS34: 100*(CLOSE-Var4)/Var4;
CYS无穷: 100*(CLOSE-Var5)/Var5;
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
4,CYE市场趋势
MAL:=MA(CLOSE,5);
MAS:=MA(MA(CLOSE,20),5);
CYEL:MAL-REF(MAL,1)/REF(MAL,1)*100;
CYES:MAS-REF(MAS,1)/REF(MAS,1)*100;
5,CYR市场强弱
DIVE:=0.01*EMA(AMOUNT,N)/EMA(VOL,N);
CYR:=DIVE/REF(DIVE,1)-1*100;
MACYR:MA(CYR,M);
n:=0,100,13
m:=0,100,5
6,CYQKL博弈K线
100*(WINNER(CLOSE)-WINNER(OPEN)), COLORSTICK;
7,CYOBV优化累积能量
NOBV1: SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),N)/CAPITAL;
n:=0,100,34
8,CYF市场能量
HSL:=VOL/CAPITAL*100;
CYF:100-100/(1+EMA(HSL,N)*100);
n:=0,100,21
9,CYDD动态承接
Var1:=WINNER(CLOSE);
Var2:=DMA(Var1,VOL/CAPITAL);
Var3:=DMA(VOL,VOL/CAPITAL)/CAPITAL;
CYDD: Var1/Var3;
CYDD1: Var2/Var3;
1, POINTDOT;
10,CYD2承接因子
A:=WINNER(CLOSE )*CAPITAL;
承接因子:A/VOL;
11,CYD承接因子
CYDS:WINNER(CLOSE)/(VOL/CAPITAL);
CYDN:WINNER(CLOSE)/MA(VOL/CAPITAL,N);
n:=0,100,21
12,CYC2成本均线
CYC1:0.01*EMA(AMOUNT,n1)/EMA(VOL,n1);
CYC2:0.01*EMA(AMOUNT,n2)/EMA(VOL,n2);
CYC3:0.01*EMA(AMOUNT,n3)/EMA(VOL,n3);
CYC∞:DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE(7)));
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
13,CYC1成本均线
Var1:=AMOUNT/(100*VOL);
短线成本均线: MA(Var1,N1);
中线成本均线: MA(Var1,N2);
长线成本均线: MA(Var1,N3);
无穷成本均线: DMA(CLOSE,VOL/CAPITAL);
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
14,CYB优化布林线
MB: MA(CLOSE,N);
上轨: MB+STD(CLOSE,N);
下轨: MB-STD(CLOSE,N);
上极限: MB+2*STD(CLOSE,N);
下极限: MB-2*STD(CLOSE,N);
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
n:=0,100,13
15,CMACD指标
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
CMACD: 100*(Var2-Var3)/Var3, COLORSTICK;
n1:=0,100,5
n2:=0,100,13
16,CBXQD成本均线
Var1:=AMOUNT/(100*VOL);
Var2:=MA(Var1,N1);
Var3:=MA(Var1,N2);
Var4:=MA(Var1,N3);
Var5:=DMA(CLOSE,VOL/CAPITAL);
CYR5: 100*(Var2-REF(Var2,N))/REF(Var2,N);
CYR13: 100*(Var3-REF(Var3,N))/REF(Var3,N);
CYR34: 100*(Var4-REF(Var4,N))/REF(Var4,N);
CYR无穷: 100*(Var5-REF(Var5,N))/REF(Var5,1);
n:=0,100,4
n1:=0,100,5
n2:=0,100,13
n3:=0,100,34
17,CBW成本带宽
CBW: 100*(COST(N1)-COST(N2))/COST(N1);
n1:=0,100,98
n2:=0,100,2
18,CBAND布林线宽
Var1:=MA(CLOSE,N);
Var2:=Var1+2*STD(CLOSE,N);
变盘: 5, POINTDOT;
布林宽度: (Var2-Var1)/Var1*100;
警戒: 30, POINTDOT;
n;=5,100,30
20,指南针CYE
顶部: 4,COLORBLUE;
强势: 1,COLORRED;
弱势: -1,colorf00ff0;
底部: -4,COLORWHITE;
短期趋势: (MA(CLOSE,5)-REF(MA(CLOSE,5),1))/REF(MA(CLOSE,5),1)*100,COLORWHITE,LINETHICK2;
中期趋势: (MA(MA(CLOSE,13),5)-REF(MA(MA(CLOSE,13),5),1))/REF(MA(MA(CLOSE,13),5),1)*100,colorf00ff0,LINETHICK2;
长期趋势: (MA(MA(CLOSE,34),5)-REF(MA(MA(CLOSE,34),5),1))/REF(MA(MA(CLOSE,34),5),1)*100,COLORRED,LINETHICK2;
21,0ama
Var1:=SMA("AMOUNT",10,1)/10000000;
Var2:=REF(Var1,1);
AA: STICKLINE(Var1>Var2,Var1,Var2,8,1),COLORRED;
AD: STICKLINE(Var1<Var2,Var1,Var2,8,0),COLORGREEN;
C5: DMA(SMA(Var1,3,1),VOL/0.02/CAPITAL);
C13: DMA(SMA(Var1,5,1),VOL/0.1/CAPITAL);
C34: DMA(SMA(Var1,8,1),VOL/0.18/CAPITAL);

指南针怎么使用

方法/步骤
1
结构、性能

1.方位测量机构:由罗盘、方位框、瞄准器及瞄准玻璃等组成。方位分划外圈为60—00密位分划制,单位为0—50密位;内圈为360º分划制,单位为5º。方位指示精度为0—25密位。

2.距离估定器:有瞄准器及瞄准玻璃等组成。瞄准玻璃上刻有距离估定线及密位分划线。当壳盖与壳身之测距定位线相对准,瞄准器处于垂直位置时,距离固定线与瞄准器组成10:1之比例测距固定器;密位分划线与瞄准器组成密位测距估定器。距离估定器的测距精度为5%。

3.俯仰角测量机构:由俯仰瞄准器、俯仰摆及锁紧机构等组成。其量程为±90º、单位为5º。俯仰角测量精度为2.5º。

4.里程测量机构:由里程测量表轮、里程表、里程表针及齿轮系等组成。里程表有1:100000;1:50000;1:25000三种分划,单位为公里。里程测量精度为2%。

5.坐标梯尺:由相互垂直的两组测尺组成。长尺80mm;短尺20mm。单位1mm。坐标梯尺测量精度为0.5mm。
2
测方位角:以判定方位、标定地图、指示目标等。

例一:测站立点至目标的磁方位角。

打开指北针,使壳盖至最大位置,将指北针托平,(单眼紧贴瞄准器)调整瞄准器的角度,使透过放大镜能清晰的看清方位指标线及所对应的分划值。瞄准时通过瞄准器上的长缝和瞄准线瞄准目标,此时方位指标线所对应的密位分划值,即为站立点至目标的磁方位角。

例二:标定地图—使地图上北方与现地正北方向一致。

展平地图,将指北针坐标梯尺长边与地图上磁北方向线(即地图中的PP'虚线)密合,此时坐标梯尺始端应指向地图下方,转动地图,使指北针方位指标线对应值指示为零。此时地图即已标定。

例三:利用地图量测站立点至目标的磁方位角。

按例二方法先将地图标定,使指北针坐标梯尺长边通过站立点和目标两点或这两点延长线,坐标梯尺的始端应指向站立点。此时方位指标线所对应之密位分划值即为站立点至目标的磁方位角。
3
估测距离:

① 已知北侧目标的间隔,估测目标至站立点之间的距离。

根据目标间隔在瞄准玻璃上所占的大小,可按10:1的比例公式或密位公式来估算距离。

比例公式:

立足点至目标的距离(米)=目标间隔宽度(米)x 10 / 目标占两估定线宽度的倍数

密位公式:

立足点至目标的距离(米)=目标间隔宽度(米)x 1000 / 目标所占的密位数

例四:已知前方目标高压电杆之间隔为50米,电杆高为8米,试用比例测距或密位测距两种方法,估测目标至站立点间的距离。

打开指北针,使壳盖与壳身之测距定位线对准,将瞄准器置于垂直位置,用单眼紧贴瞄准器长槽,通过瞄准玻璃上的分划线观察目标。

测得两电杆之间隔(50米)占两估定线宽度的倍数为1.25,通过比例公式可求得:

立足点至电杆的距离=50X10/1.25=400 米

测的电杆之高(8米)占密位分划线两小格(20密位),通过密位公式可求得:

立足点至电杆的距离=8X1000/20=400 米

② 未知被测目标的间隔,估测目标至站立点之间的距离。

例五:在河彼岸有敌阵地新建暗堡,估测暗堡至站立点之间的距离。

打开指北针,测的目标至站立点的磁方位角为45—20密位,在垂直于目标的方向寻找一辅助点,使目标至辅助点的磁方位角之值在原来的基础上变化1—00密位,例向右当测得辅助点至目标的磁方位角为44—20密位。此时用步测法或其他方法,若测得辅助点到立足点的距离为40米,则站立点到目标的距离为其十倍,即400米。

注:按上述方法测距,如再减少5%、如400米-400X5%=380米,此时测距精度能提高2%左右。

4
测俯仰角及校准水平:

用俯仰瞄准器直接瞄准目标,来测量站立点至目标的俯角或仰角。还可以将指北针的坐标梯尺(长尺)朝下,立于某一平面上,测量该平面倾斜的角度,或校准该平面,使之处于水平位置。

例六:测量站立点至山坡目标之仰角。

手拿指北针,用中指压下按键,同时通过俯仰瞄准器瞄准目标,待3-5秒钟以后,中指脱开按键,锁紧机构即将被测角度锁定。通过俯仰放大镜即可读取所测得的仰角,指示为30º。则站立点至该山坡目标的仰角为30º。
5
量测地图上任意两点之里程:

不同比例尺之地图,其方里网边长及实地距离之关系,及计算公式:

1:25,000地图:距离=量的毫米数x100/4 (公尺)

1:50,000地图:距离=量的毫米数x100/2 (公尺)

1:100,000地图:距离=量的毫米数x100 (公尺)

例七:量测地图上的甲乙两地之直线距离。(地图比例尺1:50,000)

将坐标梯尺始端对准甲地,量的甲乙两地间的长度为68毫米。

代入公式

距离=68x100/2=3400 米

责甲乙两地间的直线距离为3400米。

例八:量测沿某公路上甲乙两地之行军路程。(地图比例尺1:50000)

转动里程轮,消除其空迥,使里程表针的指示为零,然后是令程轮沿公路滚动到乙地(注意里程轮只能滚动不能滑动)。翻转指北针,根据地图的比例尺,在1:50000里程表分划圈上读数,若里程表针指示为25,则该公路上甲乙两地之路程为25公里。

说明:此法不适用于地势有起伏的地区。
6
象限法
将圆分为四个象限,当表示方位时,如在观测者的北面,则方位角度为由北向西或东起计;如方位在观测者的南面,则方位角度则由南向西或东起计。
A点在O点的方向为北45° 西 N45° W
B点在O点的方向为北60° 东 N60° E
C点在O点的方向为南55° 东 S55° E
D点在O点的方向为南50° 西 S50° W
7
方位角法
方位角从正北(即0度)起顺时针方向量度,其角度表示单位有下列3种,下图则显示各主要方向的不同表示单位。
8
量测地图上某点的坐标:

量读要领:长边压横线、短边通过点,公里数在前,尾数看尺边,先报纵坐标,后报横坐标。

例九:量测1:50000地图上、“p”点的精确坐标。

(1)先查出“p”点的坐标为83、50。将坐标梯尺长边与83坐标横线密合,使短尺通过“p”点。

(2)先后读得短边为8毫米,长边为13毫米。

带入公式:距离=量的毫米数x100/2

短边为400公尺,长边为650公尺,分别夹道所对应的公里数后面。

(3)“p”点的精确坐标为83400(纵),50650(横)。
END
注意事项
指南针务必水平地拿着,远离磁铁。白色指北,扭转身体使地图上的北方向和指南针的北方向一致,找一下你身边的标志性建筑物,在地图上找到它,你就知道你现在的位置了。

有没有short指标 的公式

有。短线指标..

指南针资金活跃市值指标源码能在同花顺中使用吗?

不能

求一个选股指标公式

我用的是玲珑软件的三行战法选股,还有指南针也自带选股,我不知道你用的是哪个软件啊,我用通达信