当前位置:首页 > 问答

up资金流向指标源码

我来帮TA回答

主力资金流入流出源码

公式没什么大用。

主力资金流向指标

资金流向的算法各大软件厂商都不一样,但大都以鹰眼个股智能跟踪系统资金流向的算法为核心,进行参数调整而开发出来。核心公式如下,仅供参考。
流通:=AMOUNT/VOL;
PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2))); ZLL:=VOL/CAPITAL;
HSL1:=IF(ZLL>10,10,ZLL);
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
STICKLINE(HSL*0.4>=0,HSL*0.4*1.5,0,1,0),COLOR808080;
STICKLINE(HSL*0.4<0,HSL*0.4*1.5,0,1,0),COLOR808080;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
资金流量:LLJX,LINICK0,COLOR0000FF;
STICKLINE(资金流量>0,资金流量,0,3,0),COLOR0000FF;
STICKLINE(资金流量<0,资金流量,0,3,0),COLORFF0000;
流量基线:GJJ,COLOR00FFFF;
ZJLL:=REF(LLJX,1);
QZJJ:=((LLJX-ZJLL)/ZJLL)*100;
流量增幅%:IF(LLJX>0 AND ZJLL<0,ABS(QZJJ),IF(LLJX<0 AND ZJLL<0 AND LLJX<ZJLL,-QZJJ,QZJJ)),LINICK0;
力度:HSL/1000,LINICK0;
周流量:SUM(LLJX,5),LINICK0;
BB:=REF(周流量,1);
ZQZJJ:=((周流量-BB)/BB)*100;
周增幅%:IF(周流量>0 AND BB<0,ABS(ZQZJJ),IF(周流量<0 AND BB<0 AND 周流量<BB,-ZQZJJ,ZQZJJ)),COLORDDD159,LINICK0;
0,COLORLICYAN;

谁有通达信中线主力资金指标公式

N:=24;
VAR1:= EMA(EMA(CLOSE,13),13);
控盘指数: (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000,POINTDOT,COLORFFCCCC;
STICKLINE(控盘指数<0,控盘指数,0,2,0),COLORGRAY;
无庄控盘: 控盘指数<0,LINICK0,COLORGRAY;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数<3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>0 AND 控盘指数>3,控盘指数,0,2,1),COLORRED;
STICKLINE(控盘指数>REF(控盘指数,1) AND 控盘指数>3,控盘指数,3,4,1),COLORFF00FF;
主力控盘: 控盘指数>REF(控盘指数,1) AND 控盘指数>0,LINICK0,COLORRED;
STICKLINE(控盘指数<REF(控盘指数,1) AND 控盘指数>0,控盘指数,0,2,0),COLOR00FF00;
控盘减弱: 控盘指数<REF(控盘指数,1) AND 控盘指数>0,LINICK0,COLOR00FF00;
VARA:= EMA(0.667*REF(控盘指数,1)+0.333*控盘指数,2);
STICKLINE(控盘指数>VARA,控盘指数,VARA,2,0),COLORRED;
B2:= 控盘指数>VARA;
准备: B2>REF(B2,1) AND 控盘指数<(-2),COLORYELLOW;
DRAWTEXT(准备,3,'准备'),COLORYELLOW;
B1:= (控盘指数>REF(控盘指数,1) AND 控盘指数>0)=1;
开始控盘: B1>REF(B1,1),COLORMAGENTA,LINICK3;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买=1,5),L*0.11,1);
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
XG2:CROSS(DIFF,DEA),NODRAW;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
DRAWTEXT(绿柱短了,MACD,'买点来了');
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
{VERTLINE(上成立,3),COLORYELLOW;
VERTLINE(下成立,3),COLORRED;}
IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINICK1;
IF(DIFF>DEA AND DIFF<0,DIFF,DRAWNULL),COLORRED,LINICK1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DRAWTEXT(FILTER(D>80,6),H*1.018,'D>80');
DRAWTEXT(FILTER(CROSS(K,D) AND D<26,6),H*0.95,'KD低位金叉'),COLORFFCCCC;
STICKLINE(FILTER(CROSS(K,D) AND D<26,6),H*0.97,H*0.95,4,0),COLORFFCCCC;
DIFFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEAF :=EMA(DIFFF,9);
MACDD:=2*(DIFFF-DEAF);
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,'MACD低位金叉'),COLORRED;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF<0,6),L-0.02,L-0.1,4,0),COLOR00FF00;
DRAWTEXT(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.25,'MACD下拐点'),COLORYELLOW;
STICKLINE(FILTER(CROSS(DIFFF,DEAF) AND DEAF>0,13),H+0.02,H+0.12,4,0),COLORBLUE;
DRAWTEXT(FILTER(CROSS(MACDD,0),13),L*0.65,'MACD上拐点'),COLORRED;
STICKLINE(FILTER(CROSS(MACDD,0),13),L*0.97,L*0.95,4,0),COLORWHITE;
ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;
STICKLINE(FILTER(CROSS(ROC,0),6),L-0.02,L-0.15,4,0),COLORFF00FF;
我是用这个的

改成大智慧资金流向指标和选股公式 谢谢

ZC_1:=IF(L<DYNAINFO(7),0,IF(H>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-H+0.02)/(H-L+0.02),0));ZC_2:=DMA(ZC_1,V/CAPITAL)*100;出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);轴:0,COLOR00FF00;PJJ:=DMA((H + L + C * 2) / 4,0.9);JJ:=REF(EMA(PJJ,3),1);QJJ:=VOL / ((H - L) * 2 - ABS(C - O));XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));ZLL:=VOL / CAPITAL;HSL1:=IF(ZLL > 10,10,ZLL);HSL:=XVL / 20 / 1.15;攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;GJJ:=EMA(攻击流量,8);LLJX:EMA(攻击流量,3);流量:LLJX,COLORRED;STICKLINE(流量 > 0,流量,0,2.3,0),COLORgreen;STICKLINE(流量 < 0,流量,0,2.3,0),COLORFF4242;流量基线:GJJ,COLORGREEN;STICKLINE(HSL * 0.4 >= 0,HSL * 0.4 * 1.5,0,0,1),COLORYELLOW;STICKLINE(HSL * 0.4 < 0,HSL * 0.4 * 1.5,0,0,1),COLORGREEN;ZJLL:=REF(LLJX,1);QZJJ:=(((LLJX - ZJLL) / ZJLL) * 100);流量幅:=IF(((LLJX > 0) AND (ZJLL < 0)),ABS(QZJJ),IF((((LLJX < 0) AND (ZJLL < 0)) AND (LLJX < ZJLL)),(0 - QZJJ),QZJJ));力度:HSL / 1000,COLORRED;周流量:=SUM(LLJX,5);BB:=REF(周流量,1);ZQZJJ:=(周流量-BB)/BB*100;周幅:=IF(周流量>0 AND BB<0,ABS(ZQZJJ),IF(周流量<0 AND BB<0 AND 周流量<BB,-ZQZJJ,ZQZJJ));VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);VARQ3:=EMA(VARQ2,10);VARQ4:=LLV(LOW,33);VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),3)*100;主力进场:STICKLINE(VARQ5>REF(VARQ5,1) AND 出货<=0,0,VARQ5,7,0 ),COLOR00FFFF;
ZC_1:=IF(L<DYNAINFO(7),0,IF(H>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-H+0.02)/(H-L+0.02),0));
ZC_2:=DMA(ZC_1,V/CAPITAL)*100;出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);VARQ3:=EMA(VARQ2,10);VARQ4:=LLV(LOW,33);VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),3)*100;选股:VARQ5>REF(VARQ5,1) AND 出货<=0;

股市中最常用的技术指标是哪个?

KDJ线MACD,BOLL,线,成交量,换手率

请问股市中哪些技术指标比较管用,较经典?

MACD是根据移动平均线较易掌握趋势变动的方向之优点所发展出来的,它是利用二条不同速度(一条变动的速率快——短期的移动平均线,另一条较慢——长期的移动平均线)的指数平滑移动平均线来计算二者之间的差离状况(DIF)作为研判行情的基础,然后再求取其DIF之9日平滑移动平均线,即MACD线。MACD实际就是运用快速与慢速移动平均线聚合与分离的征兆,来研判买进与卖进的时机和讯号。
1.MACD的基本运用方法
MACD在应用上,是以12日为快速移动平均线(12日EMA),而以26日为慢速移动平均线(26日EMA),首先计算出此两条移动平均线数值,再计算出两者数值间的差离值,即差离值(DIF)=12日EMA-26日EMA。然后根据此差离值,计算9日EMA值(即为MACD值);将DIF与MACD值分别绘出线条,然后依“交错分析法”分析,当DIF线向上突破MACD平滑线即为涨势确认之点, 也就是买入讯号。反之,当DIF线向下跌破MACD平滑线时,即为跌势确认之点,也就是卖出讯号。
MACD理论除了用以确认中期涨势或跌势之外,同时也可用来判别短期反转点。在图形中,可观察DIF与MACD两条线之间长间垂直距离的直线柱状体(其直线棒的算法很简单,只要将DIF线减去MACD线即得)。当直线棒由大开始变小,即为卖出讯号,当直线棒由最小(负数的最大)开始变大,即为买进讯号。因此我们可依据直线棒研判短期的反转点。
一般而言,在持续的涨势中,12日EMA在26日EMA之上,其间的正差离值(+DIF)会愈来愈大。反之,在跌势中,差离值可能变负(-DIF),负差离值也愈来愈大,所以当行情开始反转时,正或负差离值将会缩小。MACD理论,即利用正负差离值将会缩小。MACD理论,即利用正负差离值与其9日平滑均线的相交点,作为判断买卖讯号的依据。
2.计算方法
(1)计算平滑系数
MACD一个最大的长处,即在于其指标的平滑移动,特别是对一某些剧烈波动的市场,这种平滑移动的特性能够对价格波动作较和缓的描绘,从而大为提高资料的实用性。不过,在计算EMA前,首先必须求得平滑系数。所谓的系数,则是移动平均周期之单位数,如几天,几周等等。其公式如下:
2 平滑系数=————————— 周期单位数+1 2 如12日EMA的平滑系数为:—————— =0.1538; 12+1 2 26日EMA平滑系数为:——————=0.0741 27
(2)计算指数平均值(EMA)
一旦求得平滑系数后,即可用于EMA之运算,公式如下:
今天的指数平均值=平滑系数×(今天收盘指数-昨天的指数平均值)+昨天的指数平均值。
依公式可计算出12日EMA
2 12日EMA=———×今天收盘指数一昨天的指数平均值)+昨天的指数平均值 13 2 11 =———×今天收盘指数+———×昨天的指数平均值。 13 13 同理,26日EMA亦可计算出: 2 25 26日EMA=———×今天收盘指数+昨天收盘指数+———×昨天的指数平均值。 27 27
由于每日行情震荡波动之大小不同,并不适合以每日之收盘价来计算移动平均值,于是有需求指数(Demand Index)之产生,乃轻需求指数代表每日的收盘指数。计算时,都分别加重最近一日的份量权数(两倍),即对较近的资料赋予较大的权值,其计算方法如下:
C×2+H+L DI=———————— 4
其中,C为收盘价,H为最高价,L为最低价。
所以,上列公式中之今天收盘指数,可以需求指数来替代。
(3)计算指数平均的初值
当开始要对指数平均值,作持续性的记录时,可以将第一天的收盘价或需求指数当作指数平均的初值。若要更精确一些,则可把最近几天的收盘价或需求指数平均,以其平均价位作为初值。此外。亦可依其所选定的周期单位数,来做为计算平均值的基期数据。
3.研 判
(1)DIF与MACD在0以上,大势属多头市场。DIF向上突破MACD可作点交叉向下,只能看作行情的回档,不能看成空头市场的开始。
(2)反之,DIF与MACD在0以下,大势属空头市场。DIF向下跌破MACD,可作卖,若DIF向上突破MACD,是高价位抛售股东的股档的回补现象,也可看作少数投资者在低价位试探着去接手,只适合买入走短线。
(3)牛差离:股价出现二或三个近期低点,而MACD并不配合出现新低点,可作买;
(4)熊差高:股价出现二或三个近期高点而MACD并不配合新高点,可作卖;
(5)MACD可配合RSI(相对强弱指数)与KD(随机指数),互相弥补各自的缺点;
(6)高档二次向下交叉要大跌,低档二次向上交叉要大涨。
4.评 价
MACD技术分析,运用DIF线与MACD线之相交型态及直线棒高低点与背离现象,作为买卖讯号,尤其当市场股价走势呈一较为明确波段趋势时,MACD则可发挥其应有的功能,但当市场呈牛皮盘整格局,股价不上不下时,MACD买卖讯号较不明显。当用MACD作分析时,亦可运用其他的技术分析指标如短期K,D图形作为辅助工具,而且也可对买卖讯号作双重的确认。
其他技术指标有OBV等,相关说明可以去翼虎网的股票知识栏目技术篇去看。
http://www.ygzs8.com/Article/Index.html